MyTechBlog

How to fix “library-ms no longer working” error

I was just writing another encryption tutorial when I ran across the “Documents.library-ms” is no longer working error message whilst trying to open a library on Windows 7 and Windows 8. I can’t work out what caused this message but it seems that I’m not alone. This tutorial will show you the solution.

document_library Error Dialog

First, select all the problematic libraries, right hand click and select ‘delete’. 

Note: This won’t delete the contents of the folders. Only the shortcuts.

Document Library Delete

Click ‘yes’ to confirm the deletion.

Document Library Confirm Delete

In the sidebar, right hand click on ‘Libraries’ and select ‘Restore default libraries’.

Document Library Restore Default

You should now see the libraries correctly restored.

Document Library Fixed

You have now solved the Pictures.library-ms error message. Do you know what causes this error? Leave a comment below.

Tags:
Windows 8

I am the executive editor of MyTechBlog and founder of Wheal Media Limited. I’m studying MEng Computer Engineering at the University of Portsmouth and am currently on a years industrial placement working as a Systems Engineer.

http://www.johnwheal.co.uk
John Wheal
Get the best tutorials delivered to your inbox

Powered by MailChimp

Comments
7 comments
katieheflin
katieheflin

I have been trying to figure out how to fix this for two months.  YOU ARE AMAZING!!!! Thank you so much!!! :)

AdewaleAfolabi
AdewaleAfolabi

Thanks, simple and straightforward solution. Saved me hours. Thanks

themikkster
themikkster

Great John, that worked straight away, thanks!

But nobody seems to know what causes this?

FabioAntonioPabonMarquez
FabioAntonioPabonMarquez

This did not work!!.. But if you go to control panel and select "recovery" and clic on pictures, and then on "Recover files using recovery files history"  and clic on "Restore file"... and you are there!! problem solved!!..but I was able to do this thaks to you!!... I  have a brand new HP. PC.  and this computer has alot of problems. I so do not recomend any body to get this computer, is yunk!!.. Thank you so much for your help!!.. Fabio A. Pabon M.

steveofteamksa
steveofteamksa

Thanks John, this was a rare find an answer quick and get it fixed situation.  Most appreciated.  And as for an answer, I can only suggest that whilst using my Kaspersky and other spyware programs like spybot and malwarebytes software yesterday, something was "fixed" in the process, and then I began having this problem with the directories.  Other than that, I have no other clue for the possible cause, but it's the only thing I did differently before having this issue show up.  And I'll keep an eye on it in the future to test these programs and see if it reoccurs.  Thanks again for the help!

ilovefijitime
ilovefijitime

Hey John,  thanks a million from a completely computer illiterate, computer owner. you are a star!